Back to post index

OpenWRT on the TP-LINK WA901ND
Tags: [openwrt] [wa901nd] [networking]
Published: 26 Jan 2016 08:17
BusyBox v1.24.1 (2016-01-16 22:11:28 EST) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 DESIGNATED DRIVER (Bleeding Edge, r48257)
 -----------------------------------------------------
  * 2 oz. Orange Juice         Combine all juices in a
  * 2 oz. Pineapple Juice      tall glass filled with
  * 2 oz. Grapefruit Juice     ice, stir well.
  * 2 oz. Cranberry Juice
 -----------------------------------------------------

Compiling OpenWRT from scratch and installing it on the WA901ND was very straight forward:

My original intention was to install ZNC and proxy IRC, but there is no ZNC opkg. I attempted to scp over the ZNC package from Debian and install that but that did not work either.

using it as an access point

I haven’t been 100% happy with the wireless access point capabilities of the OpenBSD router I’m using. Plenty of people who choose to use a *BSD router hand off wireless access point responsibility to other hardware, so I decided to try that.

On mica:

# mv /etc/hostname.athn0 /etc/disabled.hostname.athn0

In this configuration, mica is 172.16.0.1, and will hand out DHCP addresses starting at 172.16.0.10. Arbitrarily I chose 172.16.0.2 as the access point’s address.

On the WA901ND, following https://wiki.openwrt.org/doc/recipes/bridgedap:

1) edit /etc/config/network:

config interface 'loopback'
		option ifname 'lo'
		option proto 'static'
		option ipaddr '127.0.0.1'
		option netmask '255.0.0.0'

config interface 'lan'
		option type 'bridge'
		option ifname 'eth0'
		option proto 'static'
		option ipaddr '172.16.0.2'
		option gateway '172.16.0.1'
		option netmask '255.255.255.0'
		option ip6assign '60'

2) edit /etc/config/wireless:

config wifi-device  radio0
		option type     mac80211
		option channel  6
		option hwmode   11g
		option path     'platform/ar934x_wmac'
		option htmode   HT20
		option disabled 0

config wifi-iface
		option device   radio0
		option network  lan
		option mode     ap
		option ssid     ...
		option encryption psk
		option key      '...'

3) disable dnsmasq:

# /etc/init.d/dnsmasq disable

Once configured, I restarted mica and the WA901ND, and it all just worked.